X
X



Minecraft 1.8.8-1.18 log4j açığı ve düzeltmesi

10.12.2021 saat 1 ile 6 arasında, Minecraft’ta 7 yıldır bulunan bir açık keşfedildi ve bu açığa göre aynı sunucuda bulunduğunuz diğer insanların , Minecraft’ın kayıt sistemi ile bilgisayarlarına bazı komutlar ile kod gönderilebildiği ortaya çıktı. Bunu gören Mojang konu hakkında 5 saat içerisinde yeni yamasını duyurdu ve 1.18.1 sürümünde bu sorunun “client” tarafında giderildiğini bize bildirdi. Fakat sunuculardaki bu tehdit hala devam ediyor…

Mojang tarafından yapılan açıklamaya göre, getirdikleri yamalarla şuan için 1.12.2 ve üstü için durum güvenli gözüküyor. Fakat bundan sonra Minecraft’ın artık en stabil sürümü 1.18.1 olarak belirlenmiştir.

Bu durum karşısında yapılan ilk önlemler ne oldu?

Tüm Minecraft sunucularında bu açığın kullanılabildiğini gören sunucu sahipleri, Mojang tarafından gelen bilgiyle de kapatılmasının doğru bir karar olduğu açıkladı. Bu açıklamadan sonra bir çok sunucu sahibi, sunucuyu bakıma alıp, düzeltmenin gelmesini beklediler.

mcexploit

Peki bu sorunu nasıl düzeltirim?

Orijinal Minecraft başlatıcısı kullanıyorsanız, başlatıcıyı açtığınızda düzelecektir. Harici başlatıcı kullanıyorsanız, kullandığınız başlatıcının geliştiricisi tarafından düzeltilmesi gerekiyor.

Ben sunucu sahibiyim, bu durumda ne yapmalıyım?

Bu sorun 1.18.1 olmayan her sunucuda şuan tehdit saçıyor. Yapmanız gereken en mantıklı hareket sunucunuzu 1.18.1 veya daha üstüne güncellemek olacaktır.

Fakat yinede alternatif olarak yapabilecekleriniz mevcuttur:

● PaperMC ekibi 1.16.5+ için gerekli düzeltmeyi sağladıklarını ve yeni yamaların hazır olduğunu açıkladılar.

● 1.12 ve altı içinde md_5 tarafından yeni “spigot” sürümleri yayınlandı.

 Fakat başka bir yazılım kullanıyorsanız ve buna destek gelmediyse, bu eklentiyi sunucularınıza kurabilirsiniz.

(Bu eklenti aynı zamanda “client” tarafında da düzeltme sağlamaktadır.)

Proxy sunucuları da bu açıktan etkilendi mi?

md_5 belirttiği üzere “BungeeCord” etkilenmedi fakat “Velocity” durumdan etkilendi. Bunun içinde PaperMC ekibi düzeltme yayınladı.


Son olarak Java sürümünüzü her daim son sürüm yapmanızı ve gerçek 1.18.1 ve üstü sürüm hariç, hiç bir sunucuda oynamamanızı öneririz.

Alt sürümlerde sorun düzeltilmiş olsa bile tehlike hala devam etmektedir. Güvenliğiniz için söylentilere kulak vermeyiniz, oynayacaksanız bile bunu sunucu sahibine sorunuz.

Aradığınız Bilgiyi Bulamıyor musunuz?

Bilgi bankasını detaylı olarak incelediniz, fakat ihtiyacınız olan bilgiyi bulamıyorsanız,

Bir Destek Talebi Oluşturun.
Faydalı Buldunuz mu?
(44 defa görüntülendi. / 0 kişi faydalı buldu.)